alexa-tracking
Kategori
Kategori
Home / FORUM / All / Tech / ... / Internet Service & Networking /
Knowledge Share - IPv6 Preview [BAB I]
1024
1024
KASKUS
51
244
https://www.kaskus.co.id/thread/000000000000000011406492/knowledge-share---ipv6-preview-bab-i

[Belajar IPv6] Knowledge Share - IPv6 Preview [BAB I]

Maap Gan... newbie.

Numpang share link mengenai IPv6.
Sehubungan dengan habisnya IPv4 di APNIC.
http://adf.ly/8cA04

Alokasi IPv6 dan Implementasinya di Indonesia (no. 14 Dunia).
No. 2 di Asia setelah Jepang
Dan no 1 di Asia Tenggara

http://www.sixxs.net/tools/grh/dfp/

-----------------------------------------------------------------
IPv6 Preview [BAB I]

Kenapa IPv6 ?

Pertumbuhan internet yang sangat cepat baik di segi pemakai internet di rumah, perkantoran, sekolah, instansi-instansi maupun perkembangan pesat perangkat telekomunikasi yang sudah mulai menggabungkan IP ke dalam teknologinya (convergence) di seluruh dunia telah menyebabkan alamat IPv4 dengan format 32 bit binary yang sudah digunakan sejak awal keberadaan internet, tidak bisa lagi menampung kebutuhan pengalamatan internet setelah jangka waktu 20 tahun kedepan atau bahkan lebih cepat dari itu.
Demikian hasil riset dan perhitungan para pakar dari komunitas terbuka internet (The Internet Engineering Task Force , IETF) menyebutkan.
Dengan hanya 32 bit format address hanya bisa menampung kebutuhan :
32
= 2 IPv4 Address
= 4,294,967,296 IPv4 Address

Bayangkan, penduduk dunia saat ini adalah 6,5 Milyard.
Jika nantinya masing2 punya satu komputer, 1 Lapotop (mobile), 1 PDA, 2 Handphone (GSM & CDMA).
Lalu setiap perangkat butuh 1 IP address untuk bisa connected each other.
Berapa jumlah IP yang dibutuhkan untuk taruhlah 3 Milyard penduduk dunia (bahkan dari 4 milyard IP versi 4 ini tidak keseluruhan bisa dipakai )?

Kekurangan alamat IPv4 ini tentu saja akan membuat perkembangan internet khususnya komunikasi data akan menjadi terganggu karena tidak ada lagi IPv4 yang bisa dialokasikan untuk setiap computer, perangkat lain yang akan terkoneksi baik ke internet maupun antar perangkat.

Langkah antisipasi awal sebenarnya sudah dilakukan dengan teknologi NAT (Network Address Translation) yang bekerja dengan cara melakukan penterjemahan satu alamat IPv4 public ke banyak IPv4 private.
Sehingga satu alamat IPv4 public bisa dipergunakan untuk banyak perangkat yang akan terkoneksi ke internet.

Teknologi ini sudah berkembang luas namun memiliki keterbatasan untuk interkoneksi antar jaringan yang cukup besar dan berbeda kebijakan pengalamatan, berikutnya kebutuhan gateway untuk penterjemahan alamat, serta keterbatasan pengembangan protocol internet terutama untuk aplikasi yang langsung terhubung satu sama lain (peer-to-peer) seperti Peer-to-Peer Games dan VoIP misalnya yang membutuhkan IPv4 public untuk bisa bekerja dengan baik.

Pada tahun 1992 IETF selaku komunitas terbuka internet membuka diskusi para pakar untuk mengatasi masalah ini dengan mencari format alamat IP generasi berikutnya setelah IPv4 (IPng, IP Next Generation) yang kemudian menghasilkan banyak RFC (request for comments) yakni dokumen stardard yang membahas protocol, program, prosedur serta konsep internet IPv6.
Setelah melalui pembahasan yang panjang, pada tahun 1995 ditetapkan melalui RFC2460 alamat IP versi 6 sebagai IP generasi berikutnya (IPng) pengganti IP versi 4.
IPv6 ini menggunakan format 128 bit binary sehingga bisa menampung kebutuhan :
128
= 2 IPv6 Address
= 340,282,366,920,938,463,463,374,607,431,768,211,456 IPv6 Address


Pengembangan IPv6 sampai saat ini sudah dilakukan oleh banyak pihak yang ada di seluruh dunia termasuk Service Provider, Internet Exchange Point, ISP regional, Militer serta Universitas.

Untuk Indonesia sendiri sudah dialokasikan 61 prefix IPv6 untuk berbagai organisasi,
mobile operator, IXP dan ISP. Dan berdasarkan data statistic dari badan pengembangan dan penyedia tunnel broker SixXS ([url]www.sixxs.net[/url]) hingga saat ini yang aktif :

http://www.sixxs.net/tools/grh/dfp/all/?country=id

-----------------------------------------------------
Beri apresiasi terhadap thread ini Gan!
Halaman 1 dari 73

IPv6 Subnetting [BAB II]

http://www.ipstories.web.id/?s=ipv6&submit=Search


Dikarenakan IPv6 sangat banyak jumlahnya maka penulisan menggunakan format standard notasi Hexadecimal (Basis 16, dari 0-9 kemudian A-F) yang terdiri dari 8 pasang Octet dan dipisahkan oleh titik dua (colon) sesuai RFC2373 & RFC3177.
Satu pasang octet terdiri dari format 16 bit binary, sehingga keseluruhan 8 pasang octet berjumlah 128 bit.

Contoh penulisan IPv6 adalah sebagai berikut :

2404:0176:0251:AB64:6CD1:5A5E:727A:424A (total 128 bit binary)
424A (2 octet) = 100001001001010 (16 bit binary)

Penulisan juga dapat dipersingkat untuk pasangan octet 0 yang berurutan menggunakan teknik kompresi 0.

2404:0176:0251:0000:0000:0000:0000:0005 dapat ditulis menjadi : 2404:176:251::5

Bahkan untuk alamat IPv6 tertentu teknik ini sangat berguna sekali dalam mempersingkat pengalamatan yang panjang, misal :

0000:0000:0000:0000:0000:0000:0000:0001 atau 0:0:0:0:0:0:0:1 menjadi ::1
0:0:0:0:0:0:0:0 menjadi ::

Layaknya IPv4, IPv6 juga memenuhi kebutuhan CIDR/VLSM yang memungkinkan untuk pembagian dan pengalokasian IPv6 menjadi lebih spesifik untuk di routingkan secara kesatuan.

IPv6 juga memiliki kelas sebagaimana IPv4 diantaranya (Sumber IANA):

- Aggregatable Global Unicast Addresses dengan bit awal 001 (2000::/3)
- Link-Local Unicast dengan bit awal 1111 1110 10 (FE80::/10)
- Site-Local Unicast Addresses dengan bit awal 1111 1110 11 (FEC0::/10)
- Multicast Addresses : dengan bit awal 1111 1111 (FF00::/8)
- ::8 diperuntukkan bagi pengalamatan yang belum di defenisikan

Detail ketentuan alokasi IPv6 dari IANA selaku badan alokasi IP seluruh dunia untuk Registry (badan yang mengelolal alokasi IP untuk wilayah tertentu, misal APNIC untuk wilayah Asia Pasific), ISP, Client (Site) serta LAN, saat ini adalah sebagai berikut :

- Registry (APNIC/RIPE/ARIN) mendapatkan alokasi : /23
- ISP mendapatkan alokasi : /32
- Site IPv6 (customer ISP) mendapatkan alokasi : /48
- LAN (customer) mendapatkan alokasi : /64

Perhitungan jumlah IPv6 Address dapat melalui rumus : 2(128-bit prefix)
Dari data alokasi diatas :
(128-32)
- ISP mendapatkan : 2 IPv6 Address
(128-48)
- Setiap Customer (Site) mendapatkan : 2 IPv6 Address
(128-64)
- Setiap LAN mendapatkan : 2 IPv6 Address

Contoh alokasi IPv6 untuk client PT. IPVSIX JAYA : 2404:170:AAA0::/48
(128-48) (80)
- Jumlah IPv6 yang diperoleh : 2 = 2 IPv6 Address
- Bisa dipecah menjadi :

2 x subnet /49

2404:170:AAA0:0::/49
2404:170:AAA0:8::/49

4 x subnet /50

2404:170:AAA0:0::/50
2404:170:AAA0:4::/50
2404:170:AAA0:8::/50
2404:170:AAA0:C::/50

8 x subnet /51

2404:170:AAA0:0::/51
2404:170:AAA0:2::/51
2404:170:AAA0:4::/51
2404:170:AAA0:6::/51
2404:170:AAA0:8::/51
2404:170:AAA0:A::/51
2404:170:AAA0:C::/51
2404:170:AAA0:E::/51 dan seterusnya…

Pertanyaan & Jawaban :
Q : Kenapa 2404:170:AAA0:: adalah /48 ?
A : 2404:170:AAA0::/48 = 2404:0170:AAA0:0000:0000:0000:0000:0000/48
Sesuai dengan ketentuan sebelumnya IPv6 memiliki total 128 bit prefix.
Dan setiap pasang Octet (2404, misalnya) memiliki 16 bit.
Maka sampai pada AAA0 jumlah bit sudah mencapai 48 (16 x 3 pasang octet).
Q : Berapa /48 diatasya dan sebelumnya ?
A : Sebelumnya adalah : 2404:170:AA9F::/48 (Hex, sesudah 9F adalah A0)
Setelahnya adalah : 2404:170:AAA1::/48
Q : Apakah 2404:170:AAA0::/48 dapat digabung (aggregate) dengan
2404:170:AAA1::/48 menjadi satu prefix /47, /46 ?
A : Dapat, aggregasi ini menghasilkan 2404:170:AAA0::/47 atau
2404:170:AAA0::/46 yang didalamnya juga termasuk :
- 2404:170:AAA2::/48
- 2404:170:AAA3::/48

IPv6 pun mendukung system pengiriman packet data berbagai type diantaranya :

- Unicast (pengiriman paket data menggunakan unicast address hanya ke satu host),
- Multicast (pengiriman paket data menggunakan multicast address dari satu host ke banyak host)
- Broadcast (pengiriman paket data menggunakan broadcast address dari satu host ke beberapa host tertentu saja).
- Anycast (pengiriman paket data menggunakan anycast address ke host terdekat yang memiliki anycast address yang sama).

Perbandingan panjang prefix (prefix-length) IPv4 dan IPv6 beserta jumlah IP.
v4 v6 Jumlah IP
/32 /128 1
/31 /127 2
/30 /126 4
/29 /125 8
/28 /124 16
/27 /123 32
/26 /122 64
/25 /121 128
/24 /120 256
/23 /119 512
/22 /118 1024
/21 /117 2048
/20 /116 4096
/19 /115 8192
/18 /114 16384
/17 /113 32768
/16 /112 65536
/15 /111 131072
/14 /110 262144
/13 /109 524288
/12 /108 1048576
/11 /107 2097152
/10 /106 4194304
/9 /105 8388608
/8 /104 16777216
/7 /103 33554432
/6 /102 67108864
/5 /101 134217728
/4 /100 268435456
/3 /99 536870912
/2 /98 1073741824
/1 /97 2147483648
/0 /96 4294967296

Lanjutan version 6.

/95 8589934592
/94 17179869184
/93 34359738368
/92 68719476736
/91 1.37439E+11
/90 2.74878E+11
/89 5.49756E+11
/88 1.09951E+12
/87 2.19902E+12
/86 4.39805E+12
/85 8.79609E+12
/84 1.75922E+13
/83 3.51844E+13 dan seterusnya.
Diubah oleh risnaini

Mekanisme Transisi IPv4 ke IPv6 [BAB III]

Mekanisme Transisi IPv6

Pergantian IPv4 ke IPv6 secara langsung adalah satu hal yang mustahil dilakukan secara
serentak di seluruh dunia internet. Oleh itu secara bertahap dilakukan process transisi.
Transisi pun dilakukan tetap menggunakan backbone IPv4 yang ada atau memang ada keinginan membangun sendiri jaringan baru IPv6 (native).

Setiap metode transisi berikut dapat dilakukan secara terpisah atau tergabung satu
dengan yang lainnya, misalnya tunneling IPv6 via IPv4 sudah mencakup dual stack IPv4 dan
IPv6 serta enkapsulasi.

Metode transisi yang dilakukan diantaranya :

a. Dual Stack
Metode ini sangat umum digunakan, IPv4 dan IPv6 address dapat berjalan bersamaan di satu perangkat di semua layer protocol. Sehingga perangkat memiliki dua alamat yakni IPv4 dan IPv6 tanpa saling bertindihan satu sama lainnnya serta memiliki gateway yang berbeda pula.
Routing table yang ada pun terdiri dari routing table IPv4 dan IPv6

Process pengiriman dan penerimaan packet data berlangsung secara terpisah.
Syarat utama untuk dual stack ini adalah system operasi harus mendukung IPv6.
Jika tidak, maka harus dilakukan upgrade versi.
Contoh di Windows XP : (ipconfig /all)

Ethernet adapter Local Area Connection:
Connection-specific DNS Suffix . :
Description . . . . . . . . ..: Realtek RTL8139 Family PCIrnet NIC
Physical Address. . . . . . : 00-02-3F-0E-51-35
Dhcp Enabled. . . . . . . . : No
IP Address. . . . . . . . . . .: 202.53.253.18 (IPv4 Address)
Subnet Mask . . . . . . . . .: 255.255.255.224
IP Address. . . . . . . . . . .: 2404:170:253::10 (IPv6 Address)
Default Gateway . . . . . .: 202.53.253.1 (Gateway Ipv4)
2404:170:253::1 (Gateway IPv6)
b. Metode Tunnel (Enkapsulasi).

Metode ini juga umum digunakan untuk menghubungkan jaringan IPv6 dengan jaringan IPv6 lainnya melalui jaringan IPv4 yang memiliki perangkat-perangkat yang tidak mendukung untuk operasional IPv6.
Prinsip dasar tunnel ini adalah membungkus (encapsulate) packet data IPv6 ke dalam format tunnel IPv4 untuk dikirim ke penerima dan dibuka lagi bungkusnya (decapsulate) yang sebelumnya terlebih dahulu di dilakukan setting koneksi tunnel IPv4 ini dari pengirim ke penerima serta sebaliknya.
Prinsip ini juga dikembangkan oleh Penyedia Tunnel Broker IPv6, terutama diperuntukkan bagi user personal menggunakan software (gratis maupun lisensi) untuk mempermudah koneksi ke jaringan internet berbasis IPv6.

c. Metode Translasi (Penterjemahan Paket IPv6 ke IPv4 dan sebaliknya).

Metode ini tidak begitu umum dilakukan karena memerlukan perangkat tambahan untuk melakukan translasi Paket IPv4 ke IPv6 dan sebaliknya :
1. Application Layer Gateway untuk teknik NAT
2. Dual Stack Relay Router untuk teknik TCP/UDP Relay

Implementasi IPv6 di FreeBSD

http://www.ipstories.web.id/?s=ipv6&submit=Search

Contoh sederhana IPv6 di FreeBSD

=========================

# IP Config [/etc/rc.conf]

ipv6_network_interfaces=”fxp0″
ipv6_ifconfig_fxp0=”2404:170:ee02:ee02::10 prefixlen 64″
ipv6_ifconfig_fxp0_alias0=”2404:170:ee02:ee03::10 prefixlen 64″ (IPv6 secondary sample).
ipv6_defaultrouter=”2404:170:ee02:ee02::1″

# DNS config [/etc/recolv.conf]

domain ipv6.risnaini.net
nameserver 2404:170:ee02:ee02::2

# Manual Directly Input IPv6 Address on # prompt :

ifconfig fxp0 inet6 2404:170:ee02:ee02::10 prefixle 64
ifconfig fxp0 inet6 2404:170:ee02:ee03::10 prefixle 64
route add -inet6 default 2404:170:ee02:ee02::1

# Simple Firewall :

(allow network 2404:170::/32 to any host)
ip6fw add 100 allow all from 2404:170::/32 to any in via fxp0

(allow network 2001:dc6::/32 to any host)
ip6fw add 200 allow all from 2001:dc6::/32 to any in via fxp0

(allow all ipv6 to host 2404:170:ee02::10)
ip6fw add 300 allow all from :: to 2404:170:ee02:ee02::10 in via fxp0

(deny other all traffic).
ip6fw add 1000 deny all from any to any in via fxp0
profile-picture
masteralfi memberi reputasi
Diubah oleh risnaini

Implementasi IPv6 di Postfix

http://www.ipstories.web.id/?s=ipv6&submit=Search

Berikut konfigurasi Postfix untuk bisa support IPv6

# LOCAL PATHNAME INFORMATION
#
# The queue_directory specifies the location of the Postfix queue.
# This is also the root directory of Postfix daemons that run chrooted.
# See the files in examples/chroot-setup for setting up Postfix chroot
# environments on different UNIX systems.

queue_directory = /var/spool/postfix

# The daemon_directory parameter specifies the location of all Postfix
# daemon programs (i.e. programs listed in the master.cf file). This
# directory must be owned by root.

daemon_directory = /usr/local/libexec/postfix

# QUEUE AND PROCESS OWNERSHIP
#
# The mail_owner parameter specifies the owner of the Postfix queue
# and of most Postfix daemon processes. Specify the name of a user
# account THAT DOES NOT SHARE ITS USER OR GROUP ID WITH OTHER ACCOUNTS
# AND THAT OWNS NO OTHER FILES OR PROCESSES ON THE SYSTEM. In
# particular, don’t specify nobody or daemon. PLEASE USE A DEDICATED
# USER.
mail_owner = postfix

# INTERNET HOST AND DOMAIN NAMES
myhostname = mail.ip-ng.6mail.com
mydomain = ip-ng.6mail.com

# SENDING MAIL
#
# The myorigin parameter specifies the domain that locally-posted
# mail appears to come from. The default is to append $myhostname,
# which is fine for small sites. If you run a domain with multiple
# machines, you should (1) change this to $mydomain and (2) set up
# a domain-wide alias database that aliases each user to
# user@that.users.mailhost.
myorigin = $myhostname

# RECEIVING MAIL
# The inet_interfaces parameter specifies the network interface
# addresses that this mail system receives mail on. By default,
# the software claims all active interfaces on the machine. The
# parameter also controls delivery of mail to [email]user@[ip.addres[/email]s].
inet_protocols = ipv6, ipv4
smtp_bind_address6 = 2404:170:ee02::10

# The mydestination parameter specifies the list of domains that this
# machine considers itself the final destination for.
mydestination = $myhostname, localhost.$mydomain, localhost, $mydomain

# REJECTING MAIL FOR UNKNOWN LOCAL USERS
# The local_recipient_maps parameter specifies optional lookup tables
# with all names or addresses of users that are local with respect
# to $mydestination, $inet_interfaces or $proxy_interfaces.
smtpd_sender_restrictions = check_sender_access hash:/usr/local/etc/postfix/sender_access, reject_non_fqdn_sender,

reject_unknown_sender_domain

# The unknown_local_recipient_reject_code specifies the SMTP server
# response code when a recipient domain matches $mydestination or
# ${proxy,inet}_interfaces, while $local_recipient_maps is non-empty
# and the recipient address or address local-part is not found.
unknown_local_recipient_reject_code = 450

# TRUST AND RELAY CONTROL
# The mynetworks parameter specifies the list of “trusted” SMTP
# clients that have more privileges than “strangers”.
mynetworks = /usr/local/etc/postfix/mynetworks

# The relay_domains parameter restricts what destinations this system will
# relay mail to. See the smtpd_recipient_restrictions description in
# postconf(5) for detailed information.
relay_domains = /usr/local/etc/postfix/relay_domains

# ALIAS DATABASE
#
# The alias_maps parameter specifies the list of alias databases used
# by the local delivery agent. The default list is system dependent.
alias_maps = hash:/usr/local/etc/postfix/aliases

# DELIVERY TO MAILBOX
#
# The home_mailbox parameter specifies the optional pathname of a
# mailbox file relative to a user’s home directory. The default
# mailbox file is /var/spool/mail/user or /var/mail/user. Specify
# “Maildir/” for qmail-style delivery (the / is required).
#
#home_mailbox = Mailbox
#home_mailbox = Maildir/

# JUNK MAIL CONTROLS
#
# The controls listed here are only a very small subset. The file
# SMTPD_ACCESS_README provides an overview.
header_checks = regexp:/usr/local/etc/postfix/header_checks

# DEBUGGING CONTROL
#
# The debug_peer_level parameter specifies the increment in verbose
# logging level when an SMTP client or server host name or address
# matches a pattern in the debug_peer_list parameter.

debug_peer_level = 2
debugger_command =
PATH=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin
xxgdb $daemon_directory/$process_name $process_id & sleep 5

# INSTALL-TIME CONFIGURATION INFORMATION
#
# The following parameters are used when installing a new Postfix version.
#
# sendmail_path: The full pathname of the Postfix sendmail command.
# This is the Sendmail-compatible mail posting interface.

sendmail_path = /usr/local/sbin/sendmail

# newaliases_path: The full pathname of the Postfix newaliases command.
# This is the Sendmail-compatible command to build alias databases.

newaliases_path = /usr/local/bin/newaliases

# mailq_path: The full pathname of the Postfix mailq command. This
# is the Sendmail-compatible mail queue listing command.

mailq_path = /usr/local/bin/mailq

# setgid_group: The group for mail submission and queue management
# commands. This must be a group name with a numerical group ID that
# is not shared with other accounts, not even with the Postfix account.

setgid_group = maildrop

# html_directory: The location of the Postfix HTML documentation.

html_directory = no

# manpage_directory: The location of the Postfix on-line manual pages.

manpage_directory = /usr/local/man

# sample_directory: The location of the Postfix sample configuration files.
# This parameter is obsolete as of Postfix 2.1.

sample_directory = /usr/local/etc/postfix

# readme_directory: The location of the Postfix README files.

readme_directory = no
Diubah oleh risnaini
wah trit bagus nih....lanjutkan gan...ane ikutan baca emoticon-Cendol (S)

kemaren baru belajar tunnel4to6 hehhee...sekalian dibabar ip6tables juga gan...emoticon-Blue Guy Cendol (S)
bujug banyak banget subnetnyaemoticon-Belo
IPtables belum implemen gan... mudah2an soon bisa nulis.
Bila panjang IPv4 keseluruhan adalah 1 Inchi, maka IPv6 keseluruhan adalah keliling bumi.....
Bisa ngasih IP sampai semua alat eletronik..

Di Korea, Kulkas sudah pakai IPv6 Gan.
Kalo telor di kulkas abis, notifikasi dikirim ke si empunya kulkas...untuk siap2 beli lagi...

Implementasi IPv6 untuk Web Server [Dual Stack] - Apache 2.x

# HTTPD.CONF

ServerRoot “/usr/local/apache2/”
Listen 80

LoadModule php5_module modules/libphp5.so
<IfModule !mpm_netware_module>

User daemon
Group daemon
</IfModule>

ServerAdmin risnaini@ipv6.indo.net.id
ServerName ipv6.risnaini.net :80
DocumentRoot “/usr/local/apache2/htdocs”

<Directory />
Options FollowSymLinks
AllowOverride None
Order deny,allow
Deny from all
</Directory>
<Directory “/usr/local/apache2//htdocs”>
Options Indexes FollowSymLinks
AllowOverride None
Order allow,deny
Allow from all
</Directory>
<IfModule dir_module>
DirectoryIndex index.html index.php index.htm
</IfModule>
<FilesMatch “^\.ht”>
Order allow,deny
Deny from all
Satisfy All
</FilesMatch>

ErrorLog logs/error_log
LogLevel warn

<IfModule log_config_module>
LogFormat “%h %l %u %t \”%r\” %>s %b \”%{Referer}i\” \”%{User-Agent}i\”" combined
LogFormat “%h %l %u %t \”%r\” %>s %b” common

<IfModule logio_module>
LogFormat “%h %l %u %t \”%r\” %>s %b \”%{Referer}i\” \”%{User-Agent}i\” %I %O” combinedio
</IfModule>
CustomLog logs/access_log common
</IfModule>

<IfModule alias_module>
ScriptAlias /cgi-bin/ “/usr/local/apache2//cgi-bin/”
</IfModule>

<IfModule cgid_module>
</IfModule>
<Directory “/usr/local/apache2//cgi-bin”>
AllowOverride None
Options None
Order allow,deny
Allow from all
</Directory>

DefaultType text/plain

<IfModule mime_module>
TypesConfig conf/mime.types
AddType application/x-compress .Z
AddType application/x-gzip .gz .tgz
</IfModule>

<IfModule ssl_module>
SSLRandomSeed startup builtin
SSLRandomSeed connect builtin
</IfModule>
AddType application/x-httpd-php .php
AddType application/x-httpd-php-source .phps

NameVirtualHost 2404:170:ee02::10:80

<VirtualHost 2404:170:ee02::10:80>
ServerName ipv6.risnaini.net
DocumentRoot /usr/local/apache2/htdocs
ServerAdmin noc-team@indo.net.id
ErrorLog /usr/local/apache2/logs/risnaini.net_error_log
CustomLog /usr/local/apache2/logs/ipv6.risnaini.net_access_log common
</VirtualHost>

LOG httpd IPv6 Access

http://www.ipstories.web.id/?s=ipv6&submit=Search

Contoh..ipv6 http access log

====================

2001:5c0:942b:0:e453:22ba:9e45:2e26 - - [24/Nov/2007:15:03:38 +0000] “GET / HTTP/1.1″ 200 3748
2001:5c0:942b:0:e453:22ba:9e45:2e26 - - [24/Nov/2007:15:03:41 +0000] “GET /intro.swf HTTP/1.1″ 200 834147
2001:5c0:942b:0:e453:22ba:9e45:2e26 - - [24/Nov/2007:15:09:58 +0000] “GET /index1.htm HTTP/1.1″ 200 1659
2001:5c0:942b:0:e453:22ba:9e45:2e26 - - [24/Nov/2007:15:10:02 +0000] “GET /white.htm HTTP/1.1″ 200 162
2001:5c0:942b:0:e453:22ba:9e45:2e26 - - [24/Nov/2007:15:10:03 +0000] “GET /ipv6.htm HTTP/1.1″ 200 1938
2001:5c0:942b:0:e453:22ba:9e45:2e26 - - [24/Nov/2007:15:10:03 +0000] “GET /white.htm HTTP/1.1″ 200 162
2001:5c0:942b:0:e453:22ba:9e45:2e26 - - [24/Nov/2007:15:10:04 +0000] “GET /white.htm HTTP/1.1″ 200 162
2001:5c0:942b:0:e453:22ba:9e45:2e26 - - [24/Nov/2007:15:10:04 +0000] “GET /top.htm HTTP/1.1″ 200 2020
2001:5c0:942b:0:e453:22ba:9e45:2e26 - - [24/Nov/2007:15:10:05 +0000] “GET /left-menu.htm HTTP/1.1″ 200 1487
2001:5c0:942b:0:e453:22ba:9e45:2e26 - - [24/Nov/2007:15:10:05 +0000] “GET /center.htm HTTP/1.1″ 200 383
2001:5c0:942b:0:e453:22ba:9e45:2e26 - - [24/Nov/2007:15:10:06 +0000] “GET /rightmenu.htm HTTP/1.1″ 200 2162
2001:5c0:942b:0:e453:22ba:9e45:2e26 - - [24/Nov/2007:15:10:07 +0000] “GET /down.htm HTTP/1.1″ 200 1795
2001:5c0:942b:0:e453:22ba:9e45:2e26 - - [24/Nov/2007:15:10:08 +0000] “GET /leftmenu.htm HTTP/1.1″ 200 2123
2001:5c0:942b:0:e453:22ba:9e45:2e26 - - [24/Nov/2007:15:10:06 +0000] “GET /ipv6.php HTTP/1.1″ 200 139
2001:5c0:942b:0:e453:22ba:9e45:2e26 - - [24/Nov/2007:15:10:09 +0000] “GET /risnaini.gif HTTP/1.1″ 200 3184
2001:5c0:942b:0:e453:22ba:9e45:2e26 - - [24/Nov/2007:15:10:10 +0000] “GET /ngn.jpg HTTP/1.1″ 200 28456
2001:5c0:942b:0:e453:22ba:9e45:2e26 - - [24/Nov/2007:15:10:10 +0000] “GET /netops-risnaini.jpg HTTP/1.1″ 200 78557
2001:5c0:942b:0:e453:22ba:9e45:2e26 - - [24/Nov/2007:15:10:35 +0000] “GET /apricot2007.jpg HTTP/1.1″ 200 18468
2001:5c0:942b:0:e453:22ba:9e45:2e26 - - [24/Nov/2007:15:10:46 +0000] “GET /rightmenu.htm HTTP/1.1″ 304 -
2001:5c0:942b:0:e453:22ba:9e45:2e26 - - [24/Nov/2007:15:10:47 +0000] “GET /down.htm HTTP/1.1″ 304 -
2001:5c0:942b:0:e453:22ba:9e45:2e26 - - [24/Nov/2007:15:10:49 +0000] “GET /imagesCA3O7Y9W.jpg HTTP/1.1″ 200 1807
2001:5c0:942b:0:e453:22ba:9e45:2e26 - - [24/Nov/2007:15:11:04 +0000] “GET /top.htm HTTP/1.1″ 304 -
2001:5c0:942b:0:e453:22ba:9e45:2e26 - - [24/Nov/2007:15:11:05 +0000] “GET /risnaini.gif HTTP/1.1″ 304 -
2001:5c0:942b:0:e453:22ba:9e45:2e26 - - [24/Nov/2007:15:11:06 +0000] “GET /ngn.jpg HTTP/1.1″ 304 -
2001:5c0:942b:0:e453:22ba:9e45:2e26 - - [24/Nov/2007:15:11:18 +0000] “GET /rightmenu.htm HTTP/1.1″ 304 -
2001:5c0:942b:0:e453:22ba:9e45:2e26 - - [24/Nov/2007:15:11:19 +0000] “GET /down.htm HTTP/1.1″ 304 -
2001:5c0:942b:0:e453:22ba:9e45:2e26 - - [24/Nov/2007:15:11:38 +0000] “GET /top.htm HTTP/1.1″ 304 -
2001:5c0:942b:0:e453:22ba:9e45:2e26 - - [24/Nov/2007:15:11:39 +0000] “GET /risnaini.gif HTTP/1.1″ 304 -
2001:5c0:942b:0:e453:22ba:9e45:2e26 - - [24/Nov/2007:15:11:40 +0000] “GET /ngn.jpg HTTP/1.1″ 304 -
2001:5c0:942b:0:e453:22ba:9e45:2e26 - - [24/Nov/2007:15:11:41 +0000] “GET /preview.htm HTTP/1.1″ 200 9272
2001:5c0:942b:0:e453:22ba:9e45:2e26 - - [24/Nov/2007:15:11:51 +0000] “GET /down.htm HTTP/1.1″ 304 -
2001:5c0:942b:0:e453:22ba:9e45:2e26 - - [24/Nov/2007:15:11:53 +0000] “GET /rightmenu.htm HTTP/1.1″ 304 -
Diubah oleh risnaini
malah pusing gw bacanya..
ga nge bababr blas soal ginian...
Agan Jambu127, iya bener emoticon-Smilie
Maaf agak detail.
Soalnya Indonesia agak lamban implementasi IPv6.
Sedangkan IPv4 sudah tidak ada lagi stocknya di APNIC. (selaku juragan IP asia pasifik)....emoticon-I Love Indonesia (S) tapi indonesia dalam hal alokasi paling banyak di asia tenggara... atau ke 3 di asia setelah Jepang dan China.
gan,ane make speedy gimana cara aktivin nya ya?
Diubah oleh risnaini
Thanks.

Tapi ga tau juga nih, kok kayaknya kita bakal lewat fase carrier-grade NAT dulu sebelum ke IPv6. Alasannya sederhana, node2 yang dipinggir (end user) males berubah. Apalagi yang dah keenakan 'mengamankan' jaringannya pake NAT(!).
nice info gan.....

gimana ya caranya implementasi pada home network (rumahan).
misalnya menggunakan mikrotik.. emoticon-Smilie
info yang bagus gan
mohon izin bookmark di thread yang bagus..buat dipelajari lg emoticon-Smilie
Quote:


Bener gan, NAT yang menyelamatkan IPv4 selama ini dari kehabisan emoticon-Smilie
Operator spt Telkom smp skr masih pakai bahkan untuk WAN, LAN...
CPE2 harus replaced = Capex (investment)
Ck ck ck.. unless kalo bisa bridging

Implementasi IPv6 di Mikrotik [Basic]

Quote:


[Powerful - Mikrotik for Outdoor Here !]
====================

[benz@mikro6] > ipv6 address add address=2404:170:dead:dead::dead/126 interface=ETHERNET
failure: cannot advertise address with prefix length not equal to 64 (use advertise=no)
[benz@mikro6] > ipv6 address add address=2404:170:dead:dead::dead/126 interface=ETHERNET advertise=no

[benz@mikro6] > ipv6 address print
Flags: X - disabled, I - invalid, D - dynamic, G - global, L - link-local, M - multicast
# ADDRESS INTERFACE ADVERTISE
1 IG 2404:170:dead:dead::dead/126 ETHERNET no

route

[benz@mikro6] > ipv6 route add gateway=2404:170:dead:dead::deae
Quote:


Mangtabs emoticon-Smilie
Kemarin Bab I, II, III, IV dan impelemtasi dipakai di bahan S2 teman ane gan.

Implementasi IPv6 di Cisco Router sebagai DHCP Server IPv6

Linknya Gan...
http://www.ipstories.web.id/?s=ipv6&submit=Search

During ID-IPv6 Task Force Event 30 October 2008 which is “Sosialisasi IPv6 & Hands On Traingin Dasar IPv6″, users able to have dual stack on their laptops. The DHCP server ran by Cisco Router 3725 with 12.3(4) T IOS version platform.

Trainer Today Cisco : Ade Yudha G (Cisco System), Christian (D-Net), Rahman Isnaini (Netsoft/IndoInternet).

Trainer Today Mikrotik : Niko (UfoAkses), Ervin A Taufik (IndoInternet).

Running Cisco as DHCP server for both IPv6 & IPv4 with NAT, configuration as below :

IPV6-GW#sh run
!
hostname IPV6-GW
!
ip subnet-zero
ip cef
!
!
no ip dhcp conflict logging
ip dhcp excluded-address 172.16.255.1
ip dhcp excluded-address 172.16.255.100
!
ip dhcp pool ipv4-postel
network 172.16.255.0 255.255.255.0
dns-server 202.159.32.2
domain-name ipv4.postel.go.id
netbios-node-type h-node
default-router 172.16.255.1
!
!
ip name-server 202.159.32.2
ip name-server 202.159.33.2
ip ips po max-events 100
ipv6 unicast-routing
ipv6 dhcp pool ipv6-postel
prefix-delegation 2404:170emoticon-Big GrinEADemoticon-Big GrinEAD::/64 0005000400F1A4D07003
prefix-delegation pool prefix-pool lifetime 1800 60
dns-server 2404:170:32::2
domain-name ipv6.postel.go.id
!
interface FastEthernet0/0
description IPV6-BACKBONE
ip address 202.53.252.50 255.255.255.252
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
ipv6 address 2404:170:251::AA/125
ipv6 enable
!
interface Serial0/0
no ip address
shutdown
clockrate 2000000
!
interface FastEthernet0/1
description DHCP-HOTSPOT-LAN
ip address 172.16.255.1 255.255.255.0
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
ipv6 address 2404:170emoticon-Big GrinEADemoticon-Big GrinEAD::1/64
ipv6 enable
ipv6 traffic-filter DHCP-OUT out
ipv6 nd other-config-flag
ipv6 dhcp server ipv6-postel
!
interface Serial0/1
ip address 10.10.10.10 255.255.255.252
ipv6 address 2008::1/64
ipv6 enable
clockrate 2000000
!
ip classless
ip route 0.0.0.0 0.0.0.0 202.53.252.49
!
no ip http server
no ip http secure-server
ip nat inside source list 50 interface FastEthernet0/0 overload
!
!
access-list 50 permit 172.16.255.0 0.0.0.255
ipv6 route ::/0 2404:170:251::A9
!
ipv6 access-list DHCP-OUT
remark FILTER-SECURE-POSTEL-IPV6-HOSTPOT
sequence 150 deny tcp any any range ftp-data telnet
sequence 151 deny tcp any any range 135 139
sequence 152 deny tcp any any range 161 162
sequence 153 deny tcp any any eq 6029
sequence 154 deny tcp any any range 67 68
sequence 155 deny tcp any any eq gopher
sequence 156 deny tcp any any eq finger
sequence 157 deny tcp any any eq www log
sequence 158 deny tcp any any eq 87
sequence 159 deny tcp any any eq sunrpc
sequence 160 deny tcp any any eq irc
sequence 161 deny tcp any any eq 372
sequence 162 deny tcp any any eq exec
sequence 163 deny tcp any any range login klogin
sequence 164 deny tcp any any eq cmd
sequence 165 deny tcp any any eq nntp
sequence 166 deny tcp any any eq uucp
sequence 167 deny tcp any any eq lpd
sequence 168 deny tcp any any eq 37
sequence 169 deny tcp any any eq 445
sequence 170 deny tcp any eq 445 any
sequence 171 deny tcp any any eq 450
sequence 172 deny tcp any any eq 1434
sequence 173 deny tcp any eq 1434 any
sequence 174 deny tcp any any eq 1524
sequence 175 deny tcp any any eq 2000
sequence 176 deny tcp any any range 2041 2049
sequence 177 deny udp any any range 135 netbios-ss
sequence 178 deny udp any any range snmp snmptrap
sequence 179 permit udp any any eq tftp
sequence 180 deny udp any any eq 1434
sequence 181 deny udp any eq 1434 any
sequence 182 deny udp any any eq time
sequence 183 deny udp any any eq tacacs
sequence 184 deny udp any any eq bootps
sequence 185 deny udp any any eq bootpc
sequence 186 deny udp any any eq sunrpc
sequence 187 deny udp any any eq 144
sequence 188 deny udp any any eq who
sequence 189 deny udp any any eq 515
sequence 190 deny udp any any eq rip
sequence 191 deny udp any any eq 27444
sequence 192 deny udp any any eq 31335
sequence 199 permit ipv6 any 2404:170emoticon-Big GrinEAD::/48
sequence 500 deny ipv6 any any log
!
end
Diubah oleh risnaini
Halaman 1 dari 73


GDP Network
© 2019 KASKUS, PT Darta Media Indonesia. All rights reserved
Ikuti KASKUS di